What’s Vulnerable › Vulnerabilities
CVE-2024-2743: Incorrect Authorization in GitLab
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue was discovered in GitLab-EE starting with version 13.3 before 17.1.7, 17.2 before 17.2.5, and 17.3 before 17.3.2 that would allow an attacker to modify an on-demand DAST scan without permissions and leak variables.
Affected products
- GitLab: from 13.3.0 before 17.1.7; from 17.2.0 before 17.2.5; from 17.3.0 before 17.3.2 — fixed in 17.1.7, 17.2.5, 17.3.2
How to fix
Upgrade to a fixed version: GitLab 17.1.7, 17.2.5, 17.3.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/451014
- https://hackerone.com/reports/2411756
- https://about.gitlab.com/releases/2024/09/11/patch-release-gitlab-17-3-2-released/
Get alerted when CVE-2024-2743 or the next vulnerability affects your stack