What’s Vulnerable › Vulnerabilities
CVE-2024-27432: net: ethernet: mtk_eth_soc: fix PPE hanging issue
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: net: ethernet: mtk_eth_soc: fix PPE hanging issue A patch to resolve an issue was found in MediaTek's GPL-licensed SDK: In the mtk_ppe_stop() function, the PPE scan mode is not disabled before disabling the PPE. This can potentially lead to a hang during the process of disabling the PPE. Without this patch, the PPE may experience a hang during the reboot test.
Affected products
- Linux kernel: from 5.13 before 5.15.153; from 5.16 before 6.1.83; from 6.2 before 6.6.23; from 6.7 before 6.7.11; from 6.8 before 6.8.2 — fixed in 5.15.153, 6.1.83, 6.6.23, 6.7.11, 6.8.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.153, 6.1.83, 6.6.23, 6.7.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/09a1907433865b7c8ee6777e507f5126bdd38c0f
- https://git.kernel.org/stable/c/49202a8256fc50517ef06fd5e2084c4febde6369
- https://git.kernel.org/stable/c/943c14ece95eb1cf98d477462aebcbfdfd714633
- https://git.kernel.org/stable/c/9fcadd125044007351905d40c405fadc2d3bb6d6
- https://git.kernel.org/stable/c/ea80e3ed09ab2c2b75724faf5484721753e92c31
- https://git.kernel.org/stable/c/f78807362828ad01db2a9ed005bf79501b620f27
- https://git.kernel.org/stable/c/09a1907433865b7c8ee6777e507f5126bdd38c0f
- https://git.kernel.org/stable/c/49202a8256fc50517ef06fd5e2084c4febde6369
- https://git.kernel.org/stable/c/943c14ece95eb1cf98d477462aebcbfdfd714633
- https://git.kernel.org/stable/c/9fcadd125044007351905d40c405fadc2d3bb6d6
- https://git.kernel.org/stable/c/ea80e3ed09ab2c2b75724faf5484721753e92c31
- https://git.kernel.org/stable/c/f78807362828ad01db2a9ed005bf79501b620f27
Get alerted when CVE-2024-27432 or the next vulnerability affects your stack