What’s Vulnerable › Vulnerabilities
CVE-2024-27434: wifi: iwlwifi: mvm: don't set the MFP flag for the GTK
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: iwlwifi: mvm: don't set the MFP flag for the GTK The firmware doesn't need the MFP flag for the GTK, it can even make the firmware crash. in case the AP is configured with: group cipher TKIP and MFPC. We would send the GTK with cipher = TKIP and MFP which is of course not possible.
Affected products
- Linux kernel: from 6.2 before 6.6.23; from 6.7 before 6.7.11; from 6.8 before 6.8.2 — fixed in 6.6.23, 6.7.11, 6.8.2
How to fix
Upgrade to a fixed version: Linux kernel 6.6.23, 6.7.11, 6.8.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/40405cbb20eb6541c603e7b3d54ade0a7be9d715
- https://git.kernel.org/stable/c/60f6d5fc84a9fd26528a24d8a267fc6a6698b628
- https://git.kernel.org/stable/c/b4f1b0b3b91762edd19bf9d3b2e4c3a0740501f8
- https://git.kernel.org/stable/c/e35f316bce9e5733c9826120c1838f4c447b2c4c
- https://git.kernel.org/stable/c/40405cbb20eb6541c603e7b3d54ade0a7be9d715
- https://git.kernel.org/stable/c/60f6d5fc84a9fd26528a24d8a267fc6a6698b628
- https://git.kernel.org/stable/c/b4f1b0b3b91762edd19bf9d3b2e4c3a0740501f8
- https://git.kernel.org/stable/c/e35f316bce9e5733c9826120c1838f4c447b2c4c
Get alerted when CVE-2024-27434 or the next vulnerability affects your stack