What’s Vulnerable › Vulnerabilities
CVE-2024-27437: vfio/pci: Disable auto-enable of exclusive INTx IRQ
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-05 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: vfio/pci: Disable auto-enable of exclusive INTx IRQ Currently for devices requiring masking at the irqchip for INTx, ie. devices without DisINTx support, the IRQ is enabled in request_irq() and subsequently disabled as necessary to align with the masked status flag. This presents a window where the interrupt could fire between these events, resulting in the IRQ incrementing the disable depth twice. This would be unrecoverable for a user since the masked flag prevents nested enables through vfio. Instead, invert the logic using IRQF_NO_AUTOEN such that exclusive INTx is never auto-enabled, then unmask as required.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 3.6 before 6.1.84; from 6.2 before 6.6.24; from 6.7 before 6.7.12; from 6.8 before 6.8.3; from 6.8.4 through 6.8.12 — fixed in 6.1.84, 6.6.24, 6.7.12, 6.8.3
How to fix
Upgrade to a fixed version: Linux kernel 6.1.84, 6.6.24, 6.7.12, 6.8.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/139dfcc4d723ab13469881200c7d80f49d776060
- https://git.kernel.org/stable/c/26389925d6c2126fb777821a0a983adca7ee6351
- https://git.kernel.org/stable/c/2a4a666c45107206605b7b5bc20545f8aabc4fa2
- https://git.kernel.org/stable/c/3b3491ad0f80d913e7d255941d4470f4a4d9bfda
- https://git.kernel.org/stable/c/561d5e1998d58b54ce2bbbb3e843b669aa0b3db5
- https://git.kernel.org/stable/c/b7a2f0955ffceffadfe098b40b50307431f45438
- https://git.kernel.org/stable/c/bf0bc84a20e6109ab07d5dc072067bd01eb931ec
- https://git.kernel.org/stable/c/fe9a7082684eb059b925c535682e68c34d487d43
- https://git.kernel.org/stable/c/139dfcc4d723ab13469881200c7d80f49d776060
- https://git.kernel.org/stable/c/26389925d6c2126fb777821a0a983adca7ee6351
- https://git.kernel.org/stable/c/2a4a666c45107206605b7b5bc20545f8aabc4fa2
- https://git.kernel.org/stable/c/3b3491ad0f80d913e7d255941d4470f4a4d9bfda
Get alerted when CVE-2024-27437 or the next vulnerability affects your stack