What’s Vulnerable › Vulnerabilities
CVE-2024-27454
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-26 · updated 2026-06-17
- Weakness: CWE-674
Description
orjson.loads in orjson before 3.9.15 does not limit recursion for deeply nested JSON documents.
Affected products
- Ijl Orjson: before 3.9.15 — fixed in 3.9.15
How to fix
Upgrade to a fixed version: Ijl Orjson 3.9.15. Check the vendor advisory for mitigations.
References
- https://github.com/ijl/orjson/blob/master/CHANGELOG.md#3915
- https://github.com/ijl/orjson/commit/b0e4d2c06ce06c6e63981bf0276e4b7c74e5845e
- https://github.com/ijl/orjson/issues/458
- https://monicz.dev/CVE-2024-27454
- https://github.com/ijl/orjson/blob/master/CHANGELOG.md#3915
- https://github.com/ijl/orjson/commit/b0e4d2c06ce06c6e63981bf0276e4b7c74e5845e
- https://github.com/ijl/orjson/issues/458
- https://monicz.dev/CVE-2024-27454
Get alerted when CVE-2024-27454 or the next vulnerability affects your stack