What’s Vulnerable › Vulnerabilities

CVE-2024-27459

Description

The interactive service in OpenVPN 2.6.9 and earlier allows an attacker to send data causing a stack overflow which can be used to execute arbitrary code with more privileges.

Affected products

How to fix

Upgrade to a fixed version: OpenVPN 2.5.10, 2.6.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-27459 or the next vulnerability affects your stack