What’s Vulnerable › Vulnerabilities
CVE-2024-27516
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-78
Description
Server-Side Template Injection (SSTI) vulnerability in livehelperchat before 4.34v, allows remote attackers to execute arbitrary code and obtain sensitive information via the search parameter in lhc_web/modules/lhfaq/faqweight.php.
Affected products
- livehelperchat/livehelperchat: before 4.34 — fixed in 4.34
How to fix
Upgrade to a fixed version: livehelperchat/livehelperchat 4.34. Check the vendor advisory for mitigations.
References
- https://github.com/LiveHelperChat/livehelperchat/commit/a61d231526a36d4a7d8cc957914799ee1f9db0ab
- https://github.com/LiveHelperChat/livehelperchat/issues/2054
- https://github.com/LiveHelperChat/livehelperchat/commit/a61d231526a36d4a7d8cc957914799ee1f9db0ab
- https://github.com/LiveHelperChat/livehelperchat/issues/2054
Get alerted when CVE-2024-27516 or the next vulnerability affects your stack