What’s Vulnerable › Vulnerabilities
CVE-2024-2761: Genesis Blocks < 3.1.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The Genesis Blocks WordPress plugin before 3.1.3 does not properly escape data input provided to some of its blocks, allowing using with at least contributor privileges to conduct Stored XSS attacks.
Affected products
- Genesis Blocks: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: Genesis Blocks 3.1.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e092ccdc-7ea1-4937-97b7-4cdbff5e74e5/
- https://wpscan.com/vulnerability/e092ccdc-7ea1-4937-97b7-4cdbff5e74e5/
Get alerted when CVE-2024-2761 or the next vulnerability affects your stack