What’s Vulnerable › Vulnerabilities
CVE-2024-27632
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-08 · updated 2026-06-17
- Weakness: CWE-335
Description
An issue in GNU Savane v.3.12 and before allows a remote attacker to escalate privileges via the form_id in the form_header() function.
Affected products
- GNU Savane: before 3.13 — fixed in 3.13
How to fix
Upgrade to a fixed version: GNU Savane 3.13. Check the vendor advisory for mitigations.
References
- https://github.com/ally-petitt/CVE-2024-27632
- https://medium.com/%40allypetitt/how-i-found-3-cves-in-2-days-8a135eb924d3
- https://github.com/ally-petitt/CVE-2024-27632
- https://medium.com/%40allypetitt/how-i-found-3-cves-in-2-days-8a135eb924d3
Get alerted when CVE-2024-27632 or the next vulnerability affects your stack