What’s Vulnerable › Vulnerabilities
CVE-2024-2772: Contact Form Plugin by Fluent Forms for Quiz, Survey, and Drag & Drop WP Form Builder <= 5.1.13 - Authenticated (Subscriber+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form Plugin by Fluent Forms for Quiz, Survey, and Drag & Drop WP Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via form settings in all versions up to, and including, 5.1.13 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with access to the Fluent Forms settings, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This can be chained with CVE-2024-2771 for a low-privileged user to inject malicious web scripts.
Affected products
- techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder: before 5.1.14 — fixed in 5.1.14
How to fix
Upgrade to a fixed version: techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder 5.1.14. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3073857
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2ccba77c-fb90-4906-b0fe-77607ec5df1f?source=cve
- https://plugins.trac.wordpress.org/changeset/3073857
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2ccba77c-fb90-4906-b0fe-77607ec5df1f?source=cve
Get alerted when CVE-2024-2772 or the next vulnerability affects your stack