What’s Vulnerable › Vulnerabilities
CVE-2024-27758
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-12 · updated 2026-06-17
- Weakness: CWE-306
Description
In RPyC before 6.0.0, when a server exposes a method that calls the attribute named __array__ for a client-provided netref (e.g., np.array(client_netref)), a remote attacker can craft a class that results in remote code execution.
Affected products
- Rpyc Project Rpyc: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Rpyc Project Rpyc 6.0.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/renbou/957f70d27470982994f12a1d70153d09
- https://github.com/tomerfiliba-org/rpyc/security/advisories/GHSA-h5cg-53g7-gqjw
- https://gist.github.com/renbou/957f70d27470982994f12a1d70153d09
- https://github.com/tomerfiliba-org/rpyc/security/advisories/GHSA-h5cg-53g7-gqjw
Get alerted when CVE-2024-27758 or the next vulnerability affects your stack