What’s Vulnerable › Vulnerabilities
CVE-2024-2782: Contact Form Plugin by Fluent Forms for Quiz, Survey, and Drag & Drop WP Form Builder <= 5.1.16 - Missing Authorization to Setting Manipulation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-18 · updated 2026-06-17
- Weakness: CWE-862
Description
The Contact Form Plugin by Fluent Forms for Quiz, Survey, and Drag & Drop WP Form Builder plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the /wp-json/fluentform/v1/global-settings REST API endpoint in all versions up to, and including, 5.1.16. This makes it possible for unauthenticated attackers to modify all of the plugin's settings.
Affected products
- techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder: before 5.1.17 — fixed in 5.1.17
How to fix
Upgrade to a fixed version: techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder 5.1.17. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3088078/fluentform/trunk/app/Http/Policies/GlobalSettingsPolicy.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0814e7b3-404a-4db5-b564-46c9086ec048?source=cve
- https://plugins.trac.wordpress.org/changeset/3088078/fluentform/trunk/app/Http/Policies/GlobalSettingsPolicy.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0814e7b3-404a-4db5-b564-46c9086ec048?source=cve
Get alerted when CVE-2024-2782 or the next vulnerability affects your stack