What’s Vulnerable › Vulnerabilities
CVE-2024-27843
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
Description
A logic issue was addressed with improved checks. This issue is fixed in macOS Monterey 12.7.5, macOS Sonoma 14.5, macOS Ventura 13.6.7. An app may be able to elevate privileges.
Affected products
- Apple macOS: from 12.0 before 12.7.5; from 13.0 before 13.6.7; from 14.0 before 14.5 — fixed in 12.7.5, 13.6.7, 14.5
How to fix
Upgrade to a fixed version: Apple macOS 12.7.5, 13.6.7, 14.5. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/120899
- https://support.apple.com/en-us/120900
- https://support.apple.com/en-us/120903
- http://seclists.org/fulldisclosure/2024/May/12
- https://support.apple.com/en-us/HT214106
- https://support.apple.com/kb/HT214105
- https://support.apple.com/kb/HT214106
- https://support.apple.com/kb/HT214107
Get alerted when CVE-2024-27843 or the next vulnerability affects your stack