What’s Vulnerable › Vulnerabilities
CVE-2024-27906: Apache Airflow: Dag Code and Import Error Permissions Ignored
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-862
Description
Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI. Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability
Affected products
- Apache Airflow: before 2.8.2 — fixed in 2.8.2
How to fix
Upgrade to a fixed version: Apache Airflow 2.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/37290
- https://github.com/apache/airflow/pull/37468
- https://lists.apache.org/thread/on4f7t5sqr3vfgp1pvkck79wv7mq9st5
- http://www.openwall.com/lists/oss-security/2024/02/29/1
- https://github.com/apache/airflow/pull/37290
- https://github.com/apache/airflow/pull/37468
- https://lists.apache.org/thread/on4f7t5sqr3vfgp1pvkck79wv7mq9st5
Get alerted when CVE-2024-27906 or the next vulnerability affects your stack