What’s Vulnerable › Vulnerabilities
CVE-2024-27914: Reflected Cross-Site Scripting (XSS) in search engine when debug mode is enabled in GLPI
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-18 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI is a Free Asset and IT Management Software package, Data center management, ITIL Service Desk, licenses tracking and software auditing. An unauthenticated user can provide a malicious link to a GLPI administrator in order to exploit a reflected XSS vulnerability. The XSS will only trigger if the administrator navigates through the debug bar. This issue has been patched in version 10.0.13.
Affected products
- glpi-project glpi: from 10.0.8 before 10.0.13 — fixed in 10.0.13
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/69e0dee8de0c0df139b42dbfa1a8997888c2af95
- https://github.com/glpi-project/glpi/releases/tag/10.0.13
- https://github.com/glpi-project/glpi/security/advisories/GHSA-rcxj-fqr4-q34r
- https://github.com/glpi-project/glpi/commit/69e0dee8de0c0df139b42dbfa1a8997888c2af95
- https://github.com/glpi-project/glpi/releases/tag/10.0.13
- https://github.com/glpi-project/glpi/security/advisories/GHSA-rcxj-fqr4-q34r
Get alerted when CVE-2024-27914 or the next vulnerability affects your stack