What’s Vulnerable › Vulnerabilities
CVE-2024-27919: HTTP/2: memory exhaustion due to CONTINUATION frame flood
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 86.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-04 · updated 2026-06-17
- Weakness: CWE-390
Description
Envoy is a cloud-native, open-source edge and service proxy. In versions 1.29.0 and 1.29.1, theEnvoy HTTP/2 protocol stack is vulnerable to the flood of CONTINUATION frames. Envoy's HTTP/2 codec does not reset a request when header map limits have been exceeded. This allows an attacker to send an sequence of CONTINUATION frames without the END_HEADERS bit set causing unlimited memory consumption. This can lead to denial of service through memory exhaustion. Users should upgrade to versions 1.29.2 to mitigate the effects of the CONTINUATION flood. Note that this vulnerability is a regression in Envoy version 1.29.0 and 1.29.1 only. As a workaround, downgrade to version 1.28.1 or earlier or disable HTTP/2 protocol for downstream connections.
Affected products
- envoyproxy envoy: 1.29.0, 1.29.1
References
- http://www.openwall.com/lists/oss-security/2024/04/03/16
- http://www.openwall.com/lists/oss-security/2024/04/05/3
- https://github.com/envoyproxy/envoy/commit/57a02565532c18eb9df972a3e8974be3ae59f2d5
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-gghf-vfxp-799r
- http://www.openwall.com/lists/oss-security/2024/04/03/16
- http://www.openwall.com/lists/oss-security/2024/04/05/3
- https://github.com/envoyproxy/envoy/commit/57a02565532c18eb9df972a3e8974be3ae59f2d5
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-gghf-vfxp-799r
- https://www.kb.cert.org/vuls/id/421644
Get alerted when CVE-2024-27919 or the next vulnerability affects your stack