What’s Vulnerable › Vulnerabilities
CVE-2024-27920: Unsigned code template execution through workflows in projectdiscovery/nuclei
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-15 · updated 2026-06-17
- Weakness: CWE-78
Description
projectdiscovery/nuclei is a fast and customisable vulnerability scanner based on simple YAML based DSL. A significant security oversight was identified in Nuclei v3, involving the execution of unsigned code templates through workflows. This vulnerability specifically affects users utilizing custom workflows, potentially allowing the execution of malicious code on the user's system. This advisory outlines the impacted users, provides details on the security patch, and suggests mitigation strategies. The vulnerability is addressed in Nuclei v3.2.0. Users are strongly recommended to update to this version to mitigate the security risk. Users should refrain from using custom workflows if unable to upgrade immediately. Only trusted, verified workflows should be executed.
Affected products
- projectdiscovery nuclei: from 3.0.0 before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: projectdiscovery nuclei 3.2.0. Check the vendor advisory for mitigations.
References
- https://docs.projectdiscovery.io/templates/protocols/code
- https://docs.projectdiscovery.io/templates/reference/template-signing
- https://docs.projectdiscovery.io/templates/workflows/overview
- https://github.com/projectdiscovery/nuclei/pull/4822
- https://github.com/projectdiscovery/nuclei/security/advisories/GHSA-w5wx-6g2r-r78q
- https://docs.projectdiscovery.io/templates/protocols/code
- https://docs.projectdiscovery.io/templates/reference/template-signing
- https://docs.projectdiscovery.io/templates/workflows/overview
- https://github.com/projectdiscovery/nuclei/pull/4822
- https://github.com/projectdiscovery/nuclei/security/advisories/GHSA-w5wx-6g2r-r78q
Get alerted when CVE-2024-27920 or the next vulnerability affects your stack