What’s Vulnerable › Vulnerabilities
CVE-2024-27922: HTTP Handling Vulnerability in the Bare server
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-444
Description
TOMP Bare Server implements the TompHTTP bare server. A vulnerability in versions prior to 2.0.2 relates to insecure handling of HTTP requests by the @tomphttp/bare-server-node package. This flaw potentially exposes the users of the package to manipulation of their web traffic. The impact may vary depending on the specific usage of the package but it can potentially affect any system where this package is in use. The problem has been patched in version 2.0.2. As of time of publication, no specific workaround strategies have been disclosed.
Affected products
- tomphttp bare-server-node: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: tomphttp bare-server-node 2.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/tomphttp/bare-server-node/security/advisories/GHSA-86fc-f9gr-v533
- https://github.com/tomphttp/bare-server-node/security/advisories/GHSA-86fc-f9gr-v533
Get alerted when CVE-2024-27922 or the next vulnerability affects your stack