What’s Vulnerable › Vulnerabilities
CVE-2024-27926: RSSHub Cross-site Scripting vulnerability caused by internal media proxy
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-79
Description
RSSHub is an open source RSS feed generator. Starting in version 1.0.0-master.cbbd829 and prior to version 1.0.0-master.d8ca915, ahen the specially crafted image is supplied to the internal media proxy, it proxies the image without handling XSS vulnerabilities, allowing for the execution of arbitrary JavaScript code. Users who access the deliberately constructed URL are affected. This vulnerability was fixed in version 1.0.0-master.d8ca915. No known workarounds are available.
Affected products
- DIYgod RSSHub: from 1.0.0-master.cbbd829 before 1.0.0-master.d8ca915 — fixed in 1.0.0-master.d8ca915
How to fix
Upgrade to a fixed version: DIYgod RSSHub 1.0.0-master.d8ca915. Check the vendor advisory for mitigations.
References
- https://github.com/DIYgod/RSSHub/commit/4d3e5d79c1c17837e931b4cd253d2013b487aa87
- https://github.com/DIYgod/RSSHub/security/advisories/GHSA-2wqw-hr4f-xrhh
- https://github.com/DIYgod/RSSHub/commit/4d3e5d79c1c17837e931b4cd253d2013b487aa87
- https://github.com/DIYgod/RSSHub/security/advisories/GHSA-2wqw-hr4f-xrhh
Get alerted when CVE-2024-27926 or the next vulnerability affects your stack