What’s Vulnerable › Vulnerabilities
CVE-2024-27931: Insufficient permission checking in `Deno.makeTemp*` APIs
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-05 · updated 2026-06-17
- Weakness: CWE-20
Description
Deno is a JavaScript, TypeScript, and WebAssembly runtime with secure defaults. Insufficient validation of parameters in `Deno.makeTemp*` APIs would allow for creation of files outside of the allowed directories. This may allow the user to overwrite important files on the system that may affect other systems. A user may provide a prefix or suffix to a `Deno.makeTemp*` API containing path traversal characters. This is fixed in Deno 1.41.1.
Affected products
- denoland deno: before 1.41.1 — fixed in 1.41.1
How to fix
Upgrade to a fixed version: denoland deno 1.41.1. Check the vendor advisory for mitigations.
References
- https://github.com/denoland/deno/security/advisories/GHSA-hrqr-jv8w-v9jh
- https://github.com/denoland/deno/security/advisories/GHSA-hrqr-jv8w-v9jh
Get alerted when CVE-2024-27931 or the next vulnerability affects your stack