What’s Vulnerable › Vulnerabilities
CVE-2024-27935: Deno's Node.js Compatibility Runtime has Cross-Session Data Contamination
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-488
Description
Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.35.1 and prior to version 1.36.3, a vulnerability in Deno's Node.js compatibility runtime allows for cross-session data contamination during simultaneous asynchronous reads from Node.js streams sourced from sockets or files. The issue arises from the re-use of a global buffer (BUF) in stream_wrap.ts used as a performance optimization to limit allocations during these asynchronous read operations. This can lead to data intended for one session being received by another session, potentially resulting in data corruption and unexpected behavior. This affects all users of Deno that use the node.js compatibility layer for network communication or other streams, including packages that may require node.js libraries indirectly. Version 1.36.3 contains a patch for this issue.
Affected products
- denoland deno: from 1.35.1 before 1.36.3 — fixed in 1.36.3
How to fix
Upgrade to a fixed version: denoland deno 1.36.3. Check the vendor advisory for mitigations.
References
- https://github.com/denoland/deno/commit/3e9fb8aafd9834ebacd27734cea4310caaf794c6
- https://github.com/denoland/deno/issues/20188
- https://github.com/denoland/deno/security/advisories/GHSA-wrqv-pf6j-mqjp
- https://github.com/denoland/deno/commit/3e9fb8aafd9834ebacd27734cea4310caaf794c6
- https://github.com/denoland/deno/issues/20188
- https://github.com/denoland/deno/security/advisories/GHSA-wrqv-pf6j-mqjp
Get alerted when CVE-2024-27935 or the next vulnerability affects your stack