What’s Vulnerable › Vulnerabilities
CVE-2024-27936: Deno interactive permission prompt spoofing via improper ANSI stripping
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-150
Description
Deno is a JavaScript, TypeScript, and WebAssembly runtime with secure defaults. Starting in version 1.32.1 and prior to version 1.41.0 of the deno library, maliciously crafted permission request can show the spoofed permission prompt by inserting a broken ANSI escape sequence into the request contents. Deno is stripping any ANSI escape sequences from the permission prompt, but permissions given to the program are based on the contents that contain the ANSI escape sequences. Any Deno program can spoof the content of the interactive permission prompt by inserting a broken ANSI code, which allows a malicious Deno program to display the wrong file path or program name to the user. Version 1.41.0 of the deno library contains a patch for the issue.
Affected products
- denoland deno: from 1.32.1 before 1.41.0 — fixed in 1.41.0
- Deno Runtime: from 0.103.0 before 0.147.0 — fixed in 0.147.0
How to fix
Upgrade to a fixed version: denoland deno 1.41.0; Deno Runtime 0.147.0. Check the vendor advisory for mitigations.
References
- https://github.com/denoland/deno/commit/78d430103a8f6931154ddbbe19d36f3b8630286d
- https://github.com/denoland/deno/commit/7e6b94231290020b55f1d08fb03ea8132781abc5
- https://github.com/denoland/deno/security/advisories/GHSA-m4pq-fv2w-6hrw
- https://github.com/denoland/deno/commit/78d430103a8f6931154ddbbe19d36f3b8630286d
- https://github.com/denoland/deno/commit/7e6b94231290020b55f1d08fb03ea8132781abc5
- https://github.com/denoland/deno/security/advisories/GHSA-m4pq-fv2w-6hrw
Get alerted when CVE-2024-27936 or the next vulnerability affects your stack