What’s Vulnerable › Vulnerabilities
CVE-2024-27940
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability has been identified in RUGGEDCOM CROSSBOW (All versions < V5.5). The affected systems allow any authenticated user to send arbitrary SQL commands to the SQL server. An attacker could use this vulnerability to compromise the whole database.
Affected products
- Siemens RUGGEDCOM CROSSBOW: before 5.5 — fixed in 5.5
How to fix
Upgrade to a fixed version: Siemens RUGGEDCOM CROSSBOW 5.5. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/html/ssa-916916.html
- https://cert-portal.siemens.com/productcert/html/ssa-916916.html
Get alerted when CVE-2024-27940 or the next vulnerability affects your stack