What’s Vulnerable › Vulnerabilities
CVE-2024-27949: WordPress Sirv plugin <= 7.2.0 - Server Side Request Forgery (SSRF) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Sirv CDN and Image Hosting Sirv sirv.This issue affects Sirv: from n/a through <= 7.2.0.
Affected products
- sirv Image Optimizer, Resizer and CDN – Sirv: before 7.2.1 — fixed in 7.2.1
How to fix
Upgrade to a fixed version: sirv Image Optimizer, Resizer and CDN – Sirv 7.2.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/sirv/vulnerability/wordpress-sirv-plugin-7-2-0-server-side-request-forgery-ssrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/sirv/wordpress-sirv-plugin-7-2-0-server-side-request-forgery-ssrf-vulnerability?_s_id=cve
Get alerted when CVE-2024-27949 or the next vulnerability affects your stack