What’s Vulnerable › Vulnerabilities
CVE-2024-27959: WordPress APIExperts Square for WooCommerce plugin <= 4.2.9 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wpexpertsio WC Shop Sync – Integrate Square and WooCommerce for Seamless Shop Management allows Reflected XSS.This issue affects WC Shop Sync – Integrate Square and WooCommerce for Seamless Shop Management: from n/a through 4.2.9.
Affected products
- Wpexpertsio WC Shop Sync – Integrate Square and WooCommerce for Seamless Shop Management: before 4.3 — fixed in 4.3
How to fix
Upgrade to a fixed version: Wpexpertsio WC Shop Sync – Integrate Square and WooCommerce for Seamless Shop Management 4.3. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/woosquare/wordpress-apiexperts-square-for-woocommerce-plugin-4-2-9-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/woosquare/wordpress-apiexperts-square-for-woocommerce-plugin-4-2-9-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-27959 or the next vulnerability affects your stack