What’s Vulnerable › Vulnerabilities
CVE-2024-28042: SUBNET PowerSYSTEM Center Reliance on Insufficiently Trustworthy Component
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-15 · updated 2026-06-17
- Weakness: CWE-1357
Description
SUBNET Solutions Inc. has identified vulnerabilities in third-party components used in PowerSYSTEM Center.
Affected products
- SUBNET Solutions Inc. PowerSYSTEM Center: before 5.20.x.x — fixed in 5.20.x.x
How to fix
Upgrade to a fixed version: SUBNET Solutions Inc. PowerSYSTEM Center 5.20.x.x. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/news-events/ics-advisories/icsa-24-135-02
- https://www.cisa.gov/news-events/ics-advisories/icsa-24-135-02
Get alerted when CVE-2024-28042 or the next vulnerability affects your stack