What’s Vulnerable › Vulnerabilities
CVE-2024-28085
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-150
Description
wall in util-linux through 2.40, often installed with setgid tty permissions, allows escape sequences to be sent to other users' terminals through argv. (Specifically, escape sequences received from stdin are blocked, but escape sequences received from argv are not blocked.) There may be plausible scenarios where this leads to account takeover.
Affected products
- Debian Linux: 10.0
- util-linux: from 2.24 before 2.39.4 — fixed in 2.39.4
How to fix
Upgrade to a fixed version: util-linux 2.39.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/27/5
- http://www.openwall.com/lists/oss-security/2024/03/27/6
- http://www.openwall.com/lists/oss-security/2024/03/27/7
- http://www.openwall.com/lists/oss-security/2024/03/27/8
- http://www.openwall.com/lists/oss-security/2024/03/27/9
- http://www.openwall.com/lists/oss-security/2024/03/28/1
- http://www.openwall.com/lists/oss-security/2024/03/28/2
- http://www.openwall.com/lists/oss-security/2024/03/28/3
- https://github.com/skyler-ferrante/CVE-2024-28085
- https://github.com/util-linux/util-linux/security/advisories/GHSA-xv2h-c6ww-mrjq
- https://lists.debian.org/debian-lts-announce/2024/04/msg00005.html
- https://mirrors.edge.kernel.org/pub/linux/utils/util-linux/
Get alerted when CVE-2024-28085 or the next vulnerability affects your stack