What’s Vulnerable › Vulnerabilities
CVE-2024-28088
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-04 · updated 2026-06-17
- Weakness: CWE-22
Description
LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to control the final part of the path parameter in a load_chain call. This bypasses the intended behavior of loading configurations only from the hwchase17/langchain-hub GitHub repository. The outcome can be disclosure of an API key for a large language model online service, or remote code execution. (A patch is available as of release 0.1.29 of langchain-core.)
Affected products
- langchain-ai/langchain: before 0.1.12 — fixed in 0.1.12
How to fix
Upgrade to a fixed version: langchain-ai/langchain 0.1.12. Check the vendor advisory for mitigations.
References
- https://github.com/PinkDraconian/PoC-Langchain-RCE/blob/main/README.md
- https://github.com/langchain-ai/langchain/blob/f96dd57501131840b713ed7c2e86cbf1ddc2761f/libs/core/langchain_core/utils/loading.py
- https://github.com/langchain-ai/langchain/pull/18600
- https://github.com/PinkDraconian/PoC-Langchain-RCE/blob/main/README.md
- https://github.com/langchain-ai/langchain/blob/f96dd57501131840b713ed7c2e86cbf1ddc2761f/libs/core/langchain_core/utils/loading.py
- https://github.com/langchain-ai/langchain/pull/18600
Get alerted when CVE-2024-28088 or the next vulnerability affects your stack