What’s Vulnerable › Vulnerabilities
CVE-2024-28098: Apache Pulsar: Improper Authorization For Topic-Level Policy Management
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-12 · updated 2026-06-17
- Weakness: CWE-863
Description
The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Apache Pulsar users should upgrade to at least 2.10.6. 2.11 Apache Pulsar users should upgrade to at least 2.11.4. 3.0 Apache Pulsar users should upgrade to at least 3.0.3. 3.1 Apache Pulsar users should upgrade to at least 3.1.3. 3.2 Apache Pulsar users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Affected products
- Apache Software Foundation Apache Pulsar: from 2.7.1 before 2.10.6; from 2.11.0 before 2.11.4; from 3.0.0 before 3.0.3; from 3.1.0 before 3.1.3; 3.2.0 — fixed in 2.10.6, 2.11.4, 3.0.3, 3.1.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pulsar 2.10.6, 2.11.4, 3.0.3, 3.1.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/12/12
- https://lists.apache.org/thread/3m6923y3wxpdcs9346sjvt8ql9swqc2z
- https://pulsar.apache.org/security/CVE-2024-28098/
- http://www.openwall.com/lists/oss-security/2024/03/12/12
- https://lists.apache.org/thread/3m6923y3wxpdcs9346sjvt8ql9swqc2z
- https://pulsar.apache.org/security/CVE-2024-28098/
Get alerted when CVE-2024-28098 or the next vulnerability affects your stack