What’s Vulnerable › Vulnerabilities
CVE-2024-28101: Apollo Router's Compressed Payloads do not respect HTTP Payload Limits
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-409
Description
The Apollo Router is a graph router written in Rust to run a federated supergraph that uses Apollo Federation. Versions 0.9.5 until 1.40.2 are subject to a Denial-of-Service (DoS) type vulnerability. When receiving compressed HTTP payloads, affected versions of the Router evaluate the `limits.http_max_request_bytes` configuration option after the entirety of the compressed payload is decompressed. If affected versions of the Router receive highly compressed payloads, this could result in significant memory consumption while the compressed payload is expanded. Router version 1.40.2 has a fix for the vulnerability. Those who are unable to upgrade may be able to implement mitigations at proxies or load balancers positioned in front of their Router fleet (e.g. Nginx, HAProxy, or cloud-native WAF services) by creating limits on HTTP body upload size.
Affected products
- apollographql router: from 0.9.5 before 1.40.2 — fixed in 1.40.2
How to fix
Upgrade to a fixed version: apollographql router 1.40.2. Check the vendor advisory for mitigations.
References
- https://github.com/apollographql/router/commit/9e9527c73c8f34fc8438b09066163cd42520f413
- https://github.com/apollographql/router/security/advisories/GHSA-cgqf-3cq5-wvcj
- https://github.com/apollographql/router/commit/9e9527c73c8f34fc8438b09066163cd42520f413
- https://github.com/apollographql/router/security/advisories/GHSA-cgqf-3cq5-wvcj
Get alerted when CVE-2024-28101 or the next vulnerability affects your stack