What’s Vulnerable › Vulnerabilities
CVE-2024-28106: phpMyFAQ Stored XSS at FAQ News Content
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. By manipulating the news parameter in a POST request, an attacker can inject malicious JavaScript code. Upon browsing to the compromised news page, the XSS payload triggers. This vulnerability is fixed in 3.2.6.
Affected products
- thorsten phpMyFAQ: 3.2.5
References
- https://github.com/thorsten/phpMyFAQ/commit/c94b3deadd87789389e1fad162bc3dd595c0e15a
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-6p68-36m6-392r
- https://github.com/thorsten/phpMyFAQ/commit/c94b3deadd87789389e1fad162bc3dd595c0e15a
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-6p68-36m6-392r
Get alerted when CVE-2024-28106 or the next vulnerability affects your stack