What’s Vulnerable › Vulnerabilities
CVE-2024-28107: phpMyFAQ SQL injections at insertentry & saveentry
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-25 · updated 2026-06-17
- Weakness: CWE-89
Description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. A SQL injection vulnerability has been discovered in the `insertentry` & `saveentry` when modifying records due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve RCE. This vulnerability is fixed in 3.2.6.
Affected products
- thorsten phpMyFAQ: 3.2.5
References
- https://github.com/thorsten/phpMyFAQ/commit/d0fae62a72615d809e6710861c1a7f67ac893007
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-2grw-mc9r-822r
- https://github.com/thorsten/phpMyFAQ/commit/d0fae62a72615d809e6710861c1a7f67ac893007
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-2grw-mc9r-822r
Get alerted when CVE-2024-28107 or the next vulnerability affects your stack