What’s Vulnerable › Vulnerabilities
CVE-2024-28114: Remote Code Execution using Server Side Template Injection in Peering Manager
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-12 · updated 2026-06-17
- Weakness: CWE-74
Description
Peering Manager is a BGP session management tool. There is a Server Side Template Injection vulnerability that leads to Remote Code Execution in Peering Manager <=1.8.2. As a result arbitrary commands can be executed on the operating system that is running Peering Manager. This issue has been addressed in version 1.8.3. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- peering-manager: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: peering-manager 1.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/peering-manager/peering-manager/commit/8a865fb596c11ad7caf45aef317d8fcbce7f85ff
- https://github.com/peering-manager/peering-manager/security/advisories/GHSA-q37x-qfrx-jcv6
- https://owasp.org/www-community/attacks/Command_Injection
- https://owasp.org/www-project-web-security-testing-guide/v41/4-Web_Application_Security_Testing/07-Input_Validation_Testing/18-Testing_for_Server_Side_Template_Injection
- https://stackoverflow.com/questions/73939573/how-to-sanitise-string-of-python-code-with-python
- https://github.com/peering-manager/peering-manager/commit/8a865fb596c11ad7caf45aef317d8fcbce7f85ff
- https://github.com/peering-manager/peering-manager/security/advisories/GHSA-q37x-qfrx-jcv6
- https://owasp.org/www-community/attacks/Command_Injection
- https://owasp.org/www-project-web-security-testing-guide/v41/4-Web_Application_Security_Testing/07-Input_Validation_Testing/18-Testing_for_Server_Side_Template_Injection
- https://stackoverflow.com/questions/73939573/how-to-sanitise-string-of-python-code-with-python
Get alerted when CVE-2024-28114 or the next vulnerability affects your stack