What’s Vulnerable › Vulnerabilities
CVE-2024-28117: Grav vulnerable to Server Side Template Injection (SSTI)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-94
Description
Grav is an open-source, flat-file content management system. Prior to version 1.7.45, Grav validates accessible functions through the Utils::isDangerousFunction function, but does not impose restrictions on twig functions like twig_array_map, allowing attackers to bypass the validation and execute arbitrary commands. Twig processing of static pages can be enabled in the front matter by any administrative user allowed to create or edit pages. As the Twig processor runs unsandboxed, this behavior can be used to gain arbitrary code execution and elevate privileges on the instance. Upgrading to patched version 1.7.45 can mitigate this issue.
Affected products
- getgrav grav: before 1.7.45 — fixed in 1.7.45
How to fix
Upgrade to a fixed version: getgrav grav 1.7.45. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/commit/de1ccfa12dbcbf526104d68c1a6bc202a98698fe
- https://github.com/getgrav/grav/security/advisories/GHSA-qfv4-q44r-g7rv
- https://github.com/getgrav/grav/commit/de1ccfa12dbcbf526104d68c1a6bc202a98698fe
- https://github.com/getgrav/grav/security/advisories/GHSA-qfv4-q44r-g7rv
Get alerted when CVE-2024-28117 or the next vulnerability affects your stack