What’s Vulnerable › Vulnerabilities
CVE-2024-28119: Grav vulnerable to Server Side Template Injection (SSTI) via Twig escape handler
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-94
Description
Grav is an open-source, flat-file content management system. Prior to version 1.7.45, due to the unrestricted access to twig extension class from grav context, an attacker can redefine the escape function and execute arbitrary commands. Twig processing of static pages can be enabled in the front matter by any administrative user allowed to create or edit pages. As the Twig processor runs unsandboxed, this behavior can be used to gain arbitrary code execution and elevate privileges on the instance. Version 1.7.45 contains a patch for this issue.
Affected products
- getgrav grav: before 1.7.45 — fixed in 1.7.45
How to fix
Upgrade to a fixed version: getgrav grav 1.7.45. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/commit/de1ccfa12dbcbf526104d68c1a6bc202a98698fe
- https://github.com/getgrav/grav/security/advisories/GHSA-2m7x-c7px-hp58
- https://github.com/twigphp/Twig/blob/3.x/src/Extension/EscaperExtension.php#L99
- https://github.com/getgrav/grav/commit/de1ccfa12dbcbf526104d68c1a6bc202a98698fe
- https://github.com/getgrav/grav/security/advisories/GHSA-2m7x-c7px-hp58
- https://github.com/twigphp/Twig/blob/3.x/src/Extension/EscaperExtension.php#L99
Get alerted when CVE-2024-28119 or the next vulnerability affects your stack