What’s Vulnerable › Vulnerabilities
CVE-2024-28122: JWX vulnerable to a denial of service attack using compressed JWE message
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-09 · updated 2026-06-17
- Weakness: CWE-400
Description
JWX is Go module implementing various JWx (JWA/JWE/JWK/JWS/JWT, otherwise known as JOSE) technologies. This vulnerability allows an attacker with a trusted public key to cause a Denial-of-Service (DoS) condition by crafting a malicious JSON Web Encryption (JWE) token with an exceptionally high compression ratio. This issue has been patched in versions 1.2.29 and 2.0.21.
Affected products
- lestrrat-go jwx: before 1.2.29; from 2.0.0 before 2.0.21 — fixed in 1.2.29, 2.0.21
How to fix
Upgrade to a fixed version: lestrrat-go jwx 1.2.29, 2.0.21. Check the vendor advisory for mitigations.
References
- https://github.com/lestrrat-go/jwx/releases/tag/v1.2.29
- https://github.com/lestrrat-go/jwx/releases/tag/v2.0.21
- https://github.com/lestrrat-go/jwx/security/advisories/GHSA-hj3v-m684-v259
- https://github.com/lestrrat-go/jwx/releases/tag/v1.2.29
- https://github.com/lestrrat-go/jwx/releases/tag/v2.0.21
- https://github.com/lestrrat-go/jwx/security/advisories/GHSA-hj3v-m684-v259
Get alerted when CVE-2024-28122 or the next vulnerability affects your stack