What’s Vulnerable › Vulnerabilities
CVE-2024-28148: Apache Superset: Incorrect datasource authorization on explore REST API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-07 · updated 2026-06-17
- Weakness: CWE-863
Description
An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request.This issue affects Apache Superset: before 3.1.2. Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue.
Affected products
- Apache Superset: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Apache Superset 4.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/n27wlbd05oc6bgjh28d5pxzsrrph8dgo
- https://lists.apache.org/thread/n27wlbd05oc6bgjh28d5pxzsrrph8dgo
Get alerted when CVE-2024-28148 or the next vulnerability affects your stack