What’s Vulnerable › Vulnerabilities
CVE-2024-28149
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Jenkins HTML Publisher Plugin 1.16 through 1.32 (both inclusive) does not properly sanitize input, allowing attackers with Item/Configure permission to implement cross-site scripting (XSS) attacks and to determine whether a path on the Jenkins controller file system exists.
Affected products
- Jenkins Project Jenkins HTML Publisher Plugin: from 1.16 before 1.32.1 — fixed in 1.32.1
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins HTML Publisher Plugin 1.32.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/06/3
- https://www.jenkins.io/security/advisory/2024-03-06/#SECURITY-3301
- http://www.openwall.com/lists/oss-security/2024/03/06/3
- https://www.jenkins.io/security/advisory/2024-03-06/#SECURITY-3301
Get alerted when CVE-2024-28149 or the next vulnerability affects your stack