What’s Vulnerable › Vulnerabilities
CVE-2024-28153
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Jenkins OWASP Dependency-Check Plugin 5.4.5 and earlier does not escape vulnerability metadata from Dependency-Check reports, resulting in a stored cross-site scripting (XSS) vulnerability.
Affected products
- Jenkins Project Jenkins OWASP Dependency-Check Plugin: before 5.4.6 — fixed in 5.4.6
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins OWASP Dependency-Check Plugin 5.4.6. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/06/3
- https://www.jenkins.io/security/advisory/2024-03-06/#SECURITY-3344
- http://www.openwall.com/lists/oss-security/2024/03/06/3
- https://www.jenkins.io/security/advisory/2024-03-06/#SECURITY-3344
Get alerted when CVE-2024-28153 or the next vulnerability affects your stack