What’s Vulnerable › Vulnerabilities
CVE-2024-28155
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-06 · updated 2026-06-17
- Weakness: CWE-862
Description
Jenkins AppSpider Plugin 1.0.16 and earlier does not perform permission checks in several HTTP endpoints, allowing attackers with Overall/Read permission to obtain information about available scan config names, engine group names, and client names.
Affected products
- Jenkins Project Jenkins AppSpider Plugin: before 1.0.17 — fixed in 1.0.17
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins AppSpider Plugin 1.0.17. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/06/3
- https://www.jenkins.io/security/advisory/2024-03-06/#SECURITY-3144
- http://www.openwall.com/lists/oss-security/2024/03/06/3
- https://www.jenkins.io/security/advisory/2024-03-06/#SECURITY-3144
Get alerted when CVE-2024-28155 or the next vulnerability affects your stack