What’s Vulnerable › Vulnerabilities
CVE-2024-2818: Allocation of Resources Without Limits or Throttling in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-28 · updated 2026-06-17
- Weakness: CWE-770
Description
An issue has been discovered in GitLab CE/EE affecting all versions before 16.8.5, all versions starting from 16.9 before 16.9.3, all versions starting from 16.10 before 16.10.1. It was possible for an attacker to cause a denial of service using malicious crafted description parameter for labels.
Affected products
- GitLab: before 16.8.5; from 16.9.0 before 16.9.3; 16.10.0 — fixed in 16.8.5, 16.9.3
How to fix
Upgrade to a fixed version: GitLab 16.8.5, 16.9.3. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/434803
- https://gitlab.com/gitlab-org/gitlab/-/issues/434803
Get alerted when CVE-2024-2818 or the next vulnerability affects your stack