What’s Vulnerable › Vulnerabilities
CVE-2024-28190: Contao core bundle vulnerable to cross site scripting in the file manager
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, users can inject malicious code in filenames when uploading files (back end and front end), which is then executed in tooltips and popups in the back end. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, remove upload fields from frontend forms and disable uploads for untrusted back end users.
Affected products
- contao: from 4.0.0 before 4.13.40; from 5.0.0 before 5.3.4 — fixed in 4.13.40, 5.3.4
How to fix
Upgrade to a fixed version: contao 4.13.40, 5.3.4. Check the vendor advisory for mitigations.
References
- https://contao.org/en/security-advisories/cross-site-scripting-in-the-file-manager
- https://github.com/contao/contao/commit/878d28dbe0f408740555d6fc8b634bd3f8febfce
- https://github.com/contao/contao/commit/b794e14fff070101bf6a885da9b1a83395093b4d
- https://github.com/contao/contao/security/advisories/GHSA-v24p-7p4j-qvvf
- https://contao.org/en/security-advisories/cross-site-scripting-in-the-file-manager
- https://github.com/contao/contao/commit/878d28dbe0f408740555d6fc8b634bd3f8febfce
- https://github.com/contao/contao/commit/b794e14fff070101bf6a885da9b1a83395093b4d
- https://github.com/contao/contao/security/advisories/GHSA-v24p-7p4j-qvvf
Get alerted when CVE-2024-28190 or the next vulnerability affects your stack