What’s Vulnerable › Vulnerabilities
CVE-2024-28199: Cross-site Scripting (XSS) possible with maliciously formed HTML attribute names and values in Phlex
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-11 · updated 2026-06-17
- Weakness: CWE-79
Description
phlex is an open source framework for building object-oriented views in Ruby. There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. This was due to improper case-sensitivity in the code that was meant to prevent these attacks. If you render an `<a>` tag with an `href` attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user. If you splat user-provided attributes when rendering any HTML tag, malicious event attributes could be included in the output, executing JavaScript when the events are triggered by another user. Patches are available on RubyGems for all 1.x minor versions. Users are advised to upgrade. Users unable to upgrade should consider configuring a content security policy that does not allow `unsafe-inline`.
Affected products
- phlex-ruby phlex: before 1.0.1; from 1.2.0 before 1.2.2; from 1.3.0 before 1.3.3; 1.1.0, 1.4.0, 1.7.0, 1.9.0 — fixed in 1.0.1, 1.2.2, 1.3.3
How to fix
Upgrade to a fixed version: phlex-ruby phlex 1.0.1, 1.2.2, 1.3.3. Check the vendor advisory for mitigations.
References
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy#unsafe-inline
- https://github.com/phlex-ruby/phlex/commit/aa50c604cdee1d0ce7ef068a4c66cbd5d43f96a1
- https://github.com/phlex-ruby/phlex/security/advisories/GHSA-242p-4v39-2v8g
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy#unsafe-inline
- https://github.com/phlex-ruby/phlex/commit/aa50c604cdee1d0ce7ef068a4c66cbd5d43f96a1
- https://github.com/phlex-ruby/phlex/security/advisories/GHSA-242p-4v39-2v8g
Get alerted when CVE-2024-28199 or the next vulnerability affects your stack