What’s Vulnerable › Vulnerabilities
CVE-2024-28219: Pillow buffer overflow vulnerability
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-03 · updated 2026-06-17
- Weakness: CWE-680
Description
In _imagingcms.c in Pillow before 10.3.0, a buffer overflow exists because strcpy is used instead of strncpy.
Affected products
- Debian Linux: 10.0
- python-pillow Pillow: before 10.3.0 — fixed in 10.3.0
- Pypi Pillow: before 10.3.0; 1.0, 1.1, 1.2, 1.3, 1.4, 1.5 (+90) — fixed in 10.3.0
How to fix
Upgrade to a fixed version: python-pillow Pillow 10.3.0; Pypi Pillow 10.3.0. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2024/04/msg00008.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4XLPUT3VK4GQ6EVY525TT2QNUIXNRU5M/
- https://pillow.readthedocs.io/en/stable/releasenotes/10.3.0.html#security
- https://lists.debian.org/debian-lts-announce/2024/04/msg00008.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4XLPUT3VK4GQ6EVY525TT2QNUIXNRU5M/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4XLPUT3VK4GQ6EVY525TT2QNUIXNRU5M/
- https://pillow.readthedocs.io/en/stable/releasenotes/10.3.0.html#security
Get alerted when CVE-2024-28219 or the next vulnerability affects your stack