What’s Vulnerable › Vulnerabilities
CVE-2024-28231: Manipulated DATA Submessage causes a heap-buffer-overflow error
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-20 · updated 2026-06-17
- Weakness: CWE-122
Description
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.14.0, 2.13.4, 2.12.3, 2.10.4, and 2.6.8, manipulated DATA Submessage can cause a heap overflow error in the Fast-DDS process, causing the process to be terminated remotely. Additionally, the payload_size in the DATA Submessage packet is declared as uint32_t. When a negative number, such as -1, is input into this variable, it results in an Integer Overflow (for example, -1 gets converted to 0xFFFFFFFF). This eventually leads to a heap-buffer-overflow, causing the program to terminate. Versions 2.14.0, 2.13.4, 2.12.3, 2.10.4, and 2.6.8 contain a fix for this issue.
Affected products
- eProsima Fast-DDS: before 2.6.8; from 2.7.0 before 2.10.4; from 2.11.0 before 2.12.3; from 2.13.0 before 2.13.4 — fixed in 2.10.4, 2.12.3, 2.13.4, 2.6.8
How to fix
Upgrade to a fixed version: eProsima Fast-DDS 2.10.4, 2.12.3, 2.13.4, 2.6.8. Check the vendor advisory for mitigations.
References
- https://github.com/eProsima/Fast-DDS/commit/355706386f4af9ce74125eeec3c449b06113112b
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-9m2j-qw67-ph4w
- https://github.com/eProsima/Fast-DDS/commit/355706386f4af9ce74125eeec3c449b06113112b
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-9m2j-qw67-ph4w
Get alerted when CVE-2024-28231 or the next vulnerability affects your stack