What’s Vulnerable › Vulnerabilities
CVE-2024-28234: Contao has insufficient BBCode sanitizer
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-74
Description
Contao is an open source content management system. Starting in version 2.0.0 and prior to versions 4.13.40 and 5.3.4, it is possible to inject CSS styles via BBCode in comments. Installations are only affected if BBCode is enabled. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, disable BBCode for comments.
Affected products
- contao: from 2.0 before 4.13.40; from 5.0.0 before 5.3.4 — fixed in 4.13.40, 5.3.4
How to fix
Upgrade to a fixed version: contao 4.13.40, 5.3.4. Check the vendor advisory for mitigations.
References
- https://contao.org/en/security-advisories/insufficient-bbcode-sanitization
- https://github.com/contao/contao/commit/55b995d8d35da0d36bc6a22c53fe6423ab0c4ae2
- https://github.com/contao/contao/commit/6d42e667177c972ae7c219645593c262d7764ce2
- https://github.com/contao/contao/security/advisories/GHSA-j55w-hjpj-825g
- https://contao.org/en/security-advisories/insufficient-bbcode-sanitization
- https://github.com/contao/contao/commit/55b995d8d35da0d36bc6a22c53fe6423ab0c4ae2
- https://github.com/contao/contao/commit/6d42e667177c972ae7c219645593c262d7764ce2
- https://github.com/contao/contao/security/advisories/GHSA-j55w-hjpj-825g
Get alerted when CVE-2024-28234 or the next vulnerability affects your stack