What’s Vulnerable › Vulnerabilities
CVE-2024-28241: GlPI-Agent MSI package installation doesn't update folder security profile when using non default installation folder
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-25 · updated 2026-06-17
- Weakness: CWE-269
Description
The GLPI Agent is a generic management agent. Prior to version 1.7.2, a local user can modify GLPI-Agent code or used DLLs to modify agent logic and even gain higher privileges. Users should upgrade to GLPI-Agent 1.7.2 to receive a patch. As a workaround, use the default installation folder which involves installed folder is automatically secured by the system.
Affected products
- glpi-project glpi-agent: before 1.7.2 — fixed in 1.7.2
How to fix
Upgrade to a fixed version: glpi-project glpi-agent 1.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi-agent/commit/9a97114f595562c91b0833b4a800dd51e9df65e9
- https://github.com/glpi-project/glpi-agent/security/advisories/GHSA-3268-p58w-86hw
- https://github.com/glpi-project/glpi-agent/commit/9a97114f595562c91b0833b4a800dd51e9df65e9
- https://github.com/glpi-project/glpi-agent/security/advisories/GHSA-3268-p58w-86hw
Get alerted when CVE-2024-28241 or the next vulnerability affects your stack