What’s Vulnerable › Vulnerabilities
CVE-2024-28242: Disclosure of the existence of secret categories with custom backgrounds in Discourse
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-15 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open source platform for community discussion. In affected versions an attacker can learn that secret categories exist when they have backgrounds set. The issue is patched in the latest stable, beta and tests-passed version of Discourse. Users are advised to upgrade. Users unable to upgrade should temporarily remove category backgrounds.
Affected products
- discourse: before 3.2.0; before 3.3.0; 3.3.0, 3.3.0-beta1 — fixed in 3.2.0, 3.3.0
How to fix
Upgrade to a fixed version: discourse 3.2.0, 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/b425fbc2a28341a5627928f963519006712c3d39
- https://github.com/discourse/discourse/security/advisories/GHSA-c7q7-7f6q-2c23
- https://github.com/discourse/discourse/commit/b425fbc2a28341a5627928f963519006712c3d39
- https://github.com/discourse/discourse/security/advisories/GHSA-c7q7-7f6q-2c23
Get alerted when CVE-2024-28242 or the next vulnerability affects your stack