What’s Vulnerable › Vulnerabilities
CVE-2024-28244: KaTeX's maxExpand bypassed by Unicode sub/superscripts
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-25 · updated 2026-06-17
- Weakness: CWE-674
Description
KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using `\def` or `\newcommand` that causes a near-infinite loop, despite setting `maxExpand` to avoid such loops. KaTeX supports an option named maxExpand which aims to prevent infinitely recursive macros from consuming all available memory and/or triggering a stack overflow error. Unfortunately, support for "Unicode (sub|super)script characters" allows an attacker to bypass this limit. Each sub/superscript group instantiated a separate Parser with its own limit on macro executions, without inheriting the current count of macro executions from its parent. This has been corrected in KaTeX v0.16.10.
Affected products
- KaTeX: from 0.15.4 before 0.16.10 — fixed in 0.16.10
How to fix
Upgrade to a fixed version: KaTeX 0.16.10. Check the vendor advisory for mitigations.
References
- https://github.com/KaTeX/KaTeX/commit/085e21b5da05414efefa932570e7201a7c70e5b2
- https://github.com/KaTeX/KaTeX/security/advisories/GHSA-cvr6-37gx-v8wc
- https://github.com/KaTeX/KaTeX/commit/085e21b5da05414efefa932570e7201a7c70e5b2
- https://github.com/KaTeX/KaTeX/security/advisories/GHSA-cvr6-37gx-v8wc
Get alerted when CVE-2024-28244 or the next vulnerability affects your stack