What’s Vulnerable › Vulnerabilities
CVE-2024-2837: WP Chat App < 3.6.4 - Admin+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Chat App WordPress plugin before 3.6.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admins to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- ninjateam WP Chat App: before 3.6.4 — fixed in 3.6.4
How to fix
Upgrade to a fixed version: ninjateam WP Chat App 3.6.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/91058c48-f262-4fcc-9390-472d59d61115/
- https://wpscan.com/vulnerability/91058c48-f262-4fcc-9390-472d59d61115/
Get alerted when CVE-2024-2837 or the next vulnerability affects your stack